MSTP与PVST+综合实验

本实验集成了一些基础配置和概念。
实验需求:
1:全网建立2个MSTP域以及一个CST。域Cisco包含设备SW1,SW2。域Aruba包含设备SW4。配置SW3使用PVST并启用Cisco私有模式。
2:在SW3上配置10个Vlan,分别为Vlan 10,20,30,40,50,70,80,90,100。保证其余4台交换机可以顺利的学习到Vlan信息,但并不保存这些信息.
3:在Cisco域中,将VLAN10,20,30,40,50划入MSTP域1。将VLAN60,70,80,90,100划入MSTP域2。
在Aruba域中,将VLAN10,30,50,70,90划入MSTP域14,将VLAN20,40,60,80,100划入MSTP域15。
4:将SW1配置为Cisco域内的MSTP域2的根桥,将SW2配置为Cisco域内的MSTP域1的根桥,将SW4配置为Aruba域内MSTP域15的根桥。
5:将SW4配置为CST的根桥,SW1为备份根桥,配置CST以及MSTP拓补直径为当前最优直径。
6:将SW1的E0/1作为MSTP域1中的根端口,将SW2的E0/1作为MSTP域2中的根端口。
7:配置SW3使得对于10个VLAN的流量可以基于负载均衡的方式实现转发。

拓扑图如下:

stp

实验开始前的准备:

先把用不到的端口都Shutdown,使用的端口启为Trunk并配置封装为802.1q.

Sw1(config)#interface range ethernet 0/0-1 , ethernet 1/0-1
Sw1(config-if-range)#switchport trunk encapsulation dot1q
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#no shutdown
Sw2(config)#interface range ethernet 0/0-3
Sw2(config-if-range)#switchport trunk encapsulation dot1q
Sw2(config-if-range)#switchport mode trunk
Sw2(config-if-range)#no shutdown
Sw1(config)#interface range ethernet 0/0-3 , ethernet 1/0-1
Sw1(config-if-range)#switchport trunk encapsulation dot1q
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#no shutdown
Sw4(config)#interface range ethernet 0/0-1
Sw4(config-if-range)#switchport trunk encapsulation dot1q
Sw4(config-if-range)#switchport mode trunk
Sw4(config-if-range)#no shutdown

1.先建立MSTP和PVST:
注意:域名和Revision都要相同,并且在后面定义的VLAN项目也应该一样.

Sw1(config)#spanning-tree mode mst
Sw1(config)#spanning-tree mst configuration
Sw1(config-mst)#name Cisco
Sw1(config-mst)#revision 1
Sw2(config)#spanning-tree mode mst
Sw2(config)#spanning-tree mst configuration
Sw2(config-mst)#name Cisco
Sw2(config-mst)#revision 1
Sw3(config)#spanning-tree mode pvst
Sw3(config)#vtp mode server
Sw3(config)#vtp version 2
Sw3(config)#vtp pruning                       //开启VTP修剪
Sw3(config)#vtp domain Rex
Sw4(config)#spanning-tree mode mst
Sw4(config)#spanning-tree mst configuration
Sw4(config-mst)#name Aruba
Sw4(config-mst)#revision 1

做完这步后应该先检查1,2,4上的VTP域名是否洗刷,Revision是否一致.如果不正确则可能是中继封装的问题.
排错步骤:把出问题的接口Shutdown,在No Shutdown. 如果故障未排除,则Shutdonw接口,Default接口配置,重新配置封装和中继,然后再No Shutdown.

2.新建VLAN并且设置各个交换机的工作模式:

Sw1(config)#vtp mode client
Sw2(config)#vtp mode client
Sw4(config)#vtp mode client
Sw3(config-vlan)#vlan 10
Sw3(config-vlan)#vlan 20
Sw3(config-vlan)#vlan 30
Sw3(config-vlan)#vlan 40
Sw3(config-vlan)#vlan 50
Sw3(config-vlan)#vlan 60
Sw3(config-vlan)#vlan 70
Sw3(config-vlan)#vlan 80
Sw3(config-vlan)#vlan 90
Sw3(config-vlan)#vlan 100

3.在交换机上做好MSTP进程和VLAN的映射:

Sw1(config)#spanning-tree mst configuration
Sw1(config-mst)#instance 1 vlan 10,20,30,40,50
Sw1(config-mst)#instance 2 vlan 60,70,80,90,100
Sw2(config)#spanning-tree mst configuration
Sw2(config-mst)#instance 1 vlan 10,20,30,40,50
Sw2(config-mst)#instance 2 vlan 60,70,80,90,100
Sw4(config)#spanning-tree mst configuration
Sw4(config-mst)#instance 14 vlan 10,30,50,70,90
Sw4(config-mst)#instance 15 vlan 20,40,60,80,100

4.手动指定MSTP域内的根桥:
很简单,只要改优先级就行了.

Sw1(config)#spanning-tree mst 2 root primary
Sw2(config)#spanning-tree mst 1 root primary
Sw4(config)#spanning-tree mst 14,15 root primary

5.接下来配置整个CST的根桥,和备份根桥:
这就有点考究了,由于是MSTP和PVST混合环境,在整个CST内,MSTP整体在外界看来是一个大交换器.
而这个MSTP域与外界交流使用进程0交互.
如果希望Sw4成为整个CST的根桥,则需要设置进程0的优先级.

Sw4(config)#spanning-tree mst 0 priority

同样Sw1为整个CST的备份根桥:

Sw1(config)#spanning-tree mst 0 priority 8192                              //默认值为32768

配置CST的最佳直径:

Sw3(config)#spanning-tree vlan 1-4094 root secondary diameter 3            //与Sw3直连的有三个,Sw1和Sw2在Sw3看来是一个大交换机

6.设置MSTP域中的根端口有两种办法:把根桥端口的入站Cost值改小 或者 把另一端的端口优先级改低:
在端口配置模式下:

Sw1(config-if)#spanning-tree mst 1 cost 1999999                            //SW1的E0/1作为MSTP域1中的根端口
Sw1(config-if)#spanning-tree mst 2 port-priority 112                       //SW2的E0/1作为MSTP域2中的根端口

7.对VLAN做均衡负载是最给力的了:
正常情况下,Sw3和Sw3之间应该是所有VLAN通过E0/0,现在让VLAN 10,30,50,70,90走E0/1,
还是在Sw3的E0/1上修改Cost:

Sw3(config)#int ethernet 0/1
Sw3(config-if)#spanning-tree vlan 10,30,50,70,90 cost 18

这样VLAN 10,30,50,70,90上,E0/1就成根端口了.
但是由于SW4是为CST的根桥,如果SW4宕了,SW1这备份根桥就会成为根桥.这样均衡负载又会被打破.因为E1/0是根端口.
所以还需要在SW3上把E1/1接口的Cost改小:

Sw3(config)#int ethernet 1/1
Sw3(config-if)#spanning-tree vlan 10,30,50,70,90 cost 18